On 26.01.2022 09:44, Andrew Cooper wrote: > Several bugfixes have reduced the utility of this variable from it's original > purpose, and now all it does is aid in the setup of SCF_ist_wrmsr. > > Simplify the logic by drop the variable, and doubling up the setting of > SCF_ist_wrmsr for the PV and HVM blocks, which will make the AMD SPEC_CTRL > support easier to follow. Leave a comment explaining why SCF_ist_wrmsr is > still necessary for the VMExit case. > > No functional change. > > Signed-off-by: Andrew Cooper <[email protected]>
Reviewed-by: Jan Beulich <[email protected]>
