On Thu, Dec 16, 2021 at 05:16:05PM +0000, Andrew Cooper wrote: > On 06/12/2021 17:02, Anthony PERARD wrote: > > diff --git a/tools/libs/guest/Makefile b/tools/libs/guest/Makefile > > index 8f5f3acd21..1f4b7f7c58 100644 > > --- a/tools/libs/guest/Makefile > > +++ b/tools/libs/guest/Makefile > > @@ -103,8 +102,7 @@ NO_HEADERS_CHK := y > > > > include $(XEN_ROOT)/tools/libs/libs.mk > > > > -libxenguest.so.$(MAJOR).$(MINOR): COMPRESSION_LIBS = $(filter > > -l%,$(zlib-options)) > > -libxenguest.so.$(MAJOR).$(MINOR): APPEND_LDFLAGS += $(COMPRESSION_LIBS) -lz > > +libxenguest.so.$(MAJOR).$(MINOR): APPEND_LDFLAGS += $(ZLIB_LIBS) -lz > > Looking ZLIB vs the other compression libs, shouldn't -lz be inside > $(ZLIB_LIBS) ?
I don't think so because -lz is also used by libxenhypfs for example, and maybe go binding for libxl. It seems that the name of the variable is misleading, as it seems that -lz is zlib but $ZLIB doesn't contain it or anything that would be called zlib. -lz is check explicitly by configure and fail if missing, while $ZLIB can be empty. > Also, shouldn't this be LDLIBS rather than APPEND_LDFLAGS ? Yes, I think I'm doing that in a different patch. libs: rename LDUSELIBS to LDLIBS and use it instead of APPEND_LDFLAGS Thanks, -- Anthony PERARD