On 02/26/2018 12:35 PM, Andrew Cooper wrote: > Dispatch from the guest_{rd,wr}msr() functions, after falling through from the > !is_viridian_domain() case. > > Rename {rd,wr}msr_hypervisor_regs() to guest_{rd,wr}msr_xen() for consistency, > and because the _regs suffix isn't very appropriate. > > Update them to take a vcpu pointer rather than presuming that they act on > current, and switch to using X86EMUL_* return values. > > Signed-off-by: Andrew Cooper <andrew.coop...@citrix.com> > --- > CC: Jan Beulich <jbeul...@suse.com> > CC: Jun Nakajima <jun.nakaj...@intel.com> > CC: Paul Durrant <paul.durr...@citrix.com> > CC: Kevin Tian <kevin.t...@intel.com> > CC: Boris Ostrovsky <boris.ostrov...@oracle.com> > CC: Suravee Suthikulpanit <suravee.suthikulpa...@amd.com> > CC: Wei Liu <wei.l...@citrix.com> > CC: Roger Pau Monné <roger....@citrix.com> > CC: Sergey Dyasli <sergey.dya...@citrix.com> > --- > xen/arch/x86/hvm/svm/svm.c | 25 ++++--------------------- > xen/arch/x86/hvm/vmx/vmx.c | 24 ++++-------------------- > xen/arch/x86/msr.c | 8 ++++++++ > xen/arch/x86/pv/emul-priv-op.c | 6 ------ > xen/arch/x86/traps.c | 33 ++++++++++++++++----------------- > xen/include/asm-x86/processor.h | 4 ++-- > 6 files changed, 34 insertions(+), 66 deletions(-)
Reviewed-by: Boris Ostrovsky <boris.ostrov...@oracle.com> _______________________________________________ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel