On Wed, Jul 20, 2016 at 11:43:19AM +0200, Roger Pau Monne wrote: > On Wed, Jul 20, 2016 at 09:30:17AM +0100, Wei Liu wrote: > > Gcc 4.4.4 complained that the "pause" variable introduced in 22b430e0 > > ("xl: add option to leave domain paused after migration") shadowed > > pause(2) declaration in unistd.h. > > > > Rename "pause" to "pause_after_migration" to fix this issue. > > > > Reported-by: Boris Ostrovsky <boris.ostrov...@oracle.com> > > Signed-off-by: Wei Liu <wei.l...@citrix.com> > > Acked-by: Roger Pau Monné <roger....@citrix.com> > > Thanks, I haven't noticied that it was shadowing pause(2).
My compile test passed. Newer gcc is happy with that. I didn't bother to look into the differences between different gcc versions though. Wei. _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org https://lists.xen.org/xen-devel