On 10/02/16 16:18, Jan Beulich wrote: > >> --- a/xen/include/asm-x86/hvm/event.h >> +++ b/xen/include/asm-x86/hvm/event.h >> @@ -17,6 +17,12 @@ >> #ifndef __ASM_X86_HVM_EVENT_H__ >> #define __ASM_X86_HVM_EVENT_H__ >> >> +enum hvm_event_breakpoint_type >> +{ >> + HVM_EVENT_SOFTWARE_BREAKPOINT, >> + HVM_EVENT_SINGLESTEP_BREAKPOINT, >> +}; > I don't see what good it does to put existing constants into an > enum.
An enum was requested during review of v1, because "bool software_breakpoint" isn't a good function interface. I don't mind if #defines were used instead, but the parameter should have a semantic name used in calling code. ~Andrew _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org http://lists.xen.org/xen-devel