On Fri, 2015-09-25 at 15:51 +0100, Julien Grall wrote: > and use them in the vGIC emulation. > > The GIC registers may support different access sizes. Rather than open > coding the access for every registers, provide a set of helpers to access > them. > > The caller will have to call vgic_regN_* where N is the size of the > emulated registers.
These helpers end up as e.g. vgic_regN_read/write, but they don't really read or write anything, they just extract the required bits into a register or update the bits into a variable. Can we think of a better name? encode/decode? This might be more apparent (maybe without the need to rename) if the helpers took info->dabt.size instead of info. > [...] > +static inline void vgic_reg_clearbit(unsigned long *reg, register_t bits, Please call these ones clearbits/setbits to avoid giving the impression that they take a bit offset and just set/clear that one. Ian. _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org http://lists.xen.org/xen-devel