On 31/08/15 12:06, vijay.kil...@gmail.com wrote: > +struct its_device { > + /* Physical ITS */ > + struct its_node *its; > + /* Device ITT address */ > + paddr_t *itt_addr;
Just spotted this, why do you have a pointer to paddr_t? You store a pointer to the base virtual address and not the physical address of the ITT. So the name is also wrong. I would keep what Linux does, i.e: void *itt; > + /* Device ITT size */ > + unsigned long itt_size; > + /* LPI and event mapping */ > + struct event_lpi_map event_map; > + /* Physical Device id */ > + u32 device_id; > +}; Regards, -- Julien Grall _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org http://lists.xen.org/xen-devel