On Thu, Jun 25, 2015 at 11:29:34AM +0100, Wei Liu wrote: > On Mon, Jun 22, 2015 at 06:11:18PM +0200, Roger Pau Monne wrote: > > Introduce a new arch_setup_meminit_hvm that's going to be used to populate > > HVM domain memory. Rename arch_setup_meminit to arch_setup_meminit_hvm_pv > > arch_setup_meminit_hvm/pv > > > and introduce a stub arch_setup_meminit that will call the right meminit > > function depending on the contains type. > > > > Signed-off-by: Roger Pau Monné <roger....@citrix.com> > > Cc: Ian Jackson <ian.jack...@eu.citrix.com> > > Cc: Stefano Stabellini <stefano.stabell...@eu.citrix.com> > > Cc: Ian Campbell <ian.campb...@citrix.com> > > Cc: Wei Liu <wei.l...@citrix.com> > > Cc: Jan Beulich <jbeul...@suse.com> > > Cc: Andrew Cooper <andrew.coop...@citrix.com> > > Cc: Boris Ostrovsky <boris.ostrov...@oracle.com> > > Cc: Konrad Rzeszutek Wilk <konrad.w...@oracle.com> > > Cc: Elena Ufimtseva <elena.ufimts...@oracle.com> > > --- > > I think that both arch_setup_meminit_hvm and arch_setup_meminit_pv could be > > unified into a single meminit function. I have however not looked into it, > > and just created arch_setup_meminit_hvm based on the code in > > xc_hvm_populate_memory. > > --- > > tools/libxc/include/xc_dom.h | 8 + > > tools/libxc/xc_dom_x86.c | 365 > > +++++++++++++++++++++++++++++++++++++++++-- > > tools/libxl/libxl_dom.c | 1 + > > 3 files changed, 362 insertions(+), 12 deletions(-) > > > > diff --git a/tools/libxc/include/xc_dom.h b/tools/libxc/include/xc_dom.h > > index f7b5f0f..051a7de 100644 > > --- a/tools/libxc/include/xc_dom.h > > +++ b/tools/libxc/include/xc_dom.h > > @@ -186,6 +186,14 @@ struct xc_dom_image { > > XC_DOM_PV_CONTAINER, > > XC_DOM_HVM_CONTAINER, > > } container_type; > > + > > + /* HVM specific fields. */ > > + xen_pfn_t target_pages; > > + xen_pfn_t mmio_start; > > + xen_pfn_t mmio_size; > > + xen_pfn_t lowmem_end; > > + xen_pfn_t highmem_end; > > These fields are in xc_hvm_build_args. I think you can use that > structure.
Never mind this. I see you delete that structure later. > > > + int vga_hole; > > bool vga_hole. > > Wei. _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org http://lists.xen.org/xen-devel