On Fri, 2015-03-27 at 19:06 -0400, longtao.pang wrote:
> 1. This patch adds creation of the nested test job, when job creation
> procedure is invoked.
> 2. 'NESTED_OS_IMAGE' is the name of 'Debian ISO Images', which defined
> in standalone.config.

It will need to be defined in production-config too, and it will need to
be made available on the infra, which probably involves you telling us
which ISO is needed.

Or even better, use the same value as the existing Debian test, i.e.
debian-7.2.0-amd64-CD-1.iso which is hardcoded in make-flight but would
be better off refactored into production-config

> 3. Set nested L1's vif model as e1000 by make-flight.
> 
> Signed-off-by: longtao.pang <longtaox.p...@intel.com>

I think this needs to go after the next patch, else the recipe doesn't
exist yet.

> ---
> Changes in v7:
> Set L1's vif model as e1000 in runvar by make-flight.
> ---
>  make-flight |   21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
> 
> diff --git a/make-flight b/make-flight
> index 8ac3a87..b8f266f 100755
> --- a/make-flight
> +++ b/make-flight
> @@ -204,6 +204,26 @@ do_hvm_win7_x64_tests () {
>              all_hostflags=$most_hostflags,hvm
>  }
>  
> +do_hvm_debian_nested_tests () {
> +  if [ $xenarch != amd64 ]; then
> +    return
> +  fi
> +  if [ $dom0arch != amd64 ]; then
> +    return
> +  fi

You can do these on a line each, or even combine into one test. i.e.

    if [ $xenarch != amd64 -o $dom0arch != amd64 ]; then return; fi

> +
> +  job_create_test test-$xenarch$kern-$dom0arch-nested test-nested xl \
> +                     $xenarch $dom0arch \
> +            nested_image=$NESTED_OS_IMAGE \
> +            nested2_image=$NESTED_OS_IMAGE \

I think for clarity you should use something like nestedl1 and nestedl2
for the runvar names.

> +            bios=seabios \
> +            kernbuildjob=build-amd64-pvops \
> +            kernkind=pvops \
> +            nested_vifmodel='e1000' \
> +            device_model_version=qemu-xen \
> +            all_hostflags=$most_hostflags,hvm
> +}
> +
>  do_hvm_debian_test_one () {
>    testname=$1
>    bios=$2
> @@ -430,6 +450,7 @@ test_matrix_do_one () {
>      done
>  
>    fi
> +  do_hvm_debian_nested_tests
>    do_passthrough_tests
>  }
>  



_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to