>>> On 20.09.17 at 05:22, <yi.y....@linux.intel.com> wrote:
> On 17-09-19 09:55:28, Roger Pau Monn wrote:
>> On Tue, Sep 05, 2017 at 05:32:26PM +0800, Yi Sun wrote:
>> > @@ -1389,6 +1480,7 @@ static void psr_cpu_init(void)
>> >      unsigned int socket, cpu = smp_processor_id();
>> >      struct feat_node *feat;
>> >      struct cpuid_leaf regs;
>> > +    uint32_t reg_b;
>> 
>> Not sure of the benefit between using regs.b or reg_b (it's only 1
>> char shorter).
>> 
> You can see the 'regs' is overwritten in below codes so that the 'regs.b' is 
> not
> kept. To add a new local variable 'reg_b' here, we can avoid calling
> 'cpuid_count_leaf' for L2 CAT and MBA.

In which case - wouldn't "ebx" be a better name for the variable?

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel

Reply via email to