On 07/09/17 17:56, Andre Przywara wrote:
Hi,
Hi Andre,
On 05/09/17 18:14, mja...@caviumnetworks.com wrote:
From: Manish Jaggi <mja...@cavium.com>
Added gicv3_its_acpi_init to update host_its_list from MADT table.
For ACPI, host_its structure stores dt_node as NULL.
Signed-off-by: Manish Jaggi <mja...@cavium.com>
---
xen/arch/arm/gic-v3-its.c | 26 ++++++++++++++++++++++++++
xen/arch/arm/gic-v3.c | 2 ++
xen/include/asm-arm/gic_v3_its.h | 9 +++++++++
3 files changed, 37 insertions(+)
diff --git a/xen/arch/arm/gic-v3-its.c b/xen/arch/arm/gic-v3-its.c
index 61a6452..536b48d 100644
--- a/xen/arch/arm/gic-v3-its.c
+++ b/xen/arch/arm/gic-v3-its.c
@@ -25,6 +25,7 @@
#include <xen/rbtree.h>
#include <xen/sched.h>
#include <xen/sizes.h>
+#include <xen/acpi.h>
#include <asm/gic.h>
#include <asm/gic_v3_defs.h>
#include <asm/gic_v3_its.h>
@@ -32,6 +33,7 @@
#include <asm/page.h>
#define ITS_CMD_QUEUE_SZ SZ_1M
+#define ACPI_GICV3_ITS_MEM_SIZE SZ_64K
Although this is used for ACPI only, this size is really the architected
size for the ITS register frame and thus should be named like this,
possibly GUEST_GICV3_ITS_SIZE or so (in xen/include/public/arch-arm.h).
Which actually makes me wonder why we would need to store this size in
the data structure in the first place ...
I guess it because the size is also present on the DT :). But yes, we
should not need as the size of the ITS MMIO is fixed.
But using GUEST_GICV3_ITS_SIZE would be a bit odd as we are talking
about the host its here. So a better name would be GICV3_ITS_SIZE.
And no inclusion in xen/include/public/arch-arm.h please. gic_v3_its.h
is a more suitable place for that.
Cheers,
--
Julien Grall
_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel