On 06/02/2015 03:40, Parth Dixit wrote:
+static int map_acpi_regions(struct domain *d)
+{
+    int res;
+
+    res = acpi_map_mmio(d);
+    if ( res )
+        return res;
+
+    return 0;
+}

I don't think that splitting the code in two functions is useful. Just
implement the remapping here.
ok, will take care in next patchset.

I agree that the splitting doesn't make really sense right now (only one call is done). But the next following patches add few more calls (such has mapping ACPI blob...).

So I would keep the splitting here. I would also rename the function to prepare_acpi to make clear that we setups ACPI for DOM0.

--
Julien Grall

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to