>>> On 16.12.14 at 21:08, <julien.gr...@linaro.org> wrote:
> @@ -123,22 +124,17 @@ struct page_info;
>  struct iommu_ops {
>      int (*init)(struct domain *d);
>      void (*hwdom_init)(struct domain *d);
> -#ifdef HAS_PCI
> -    int (*add_device)(u8 devfn, struct pci_dev *);
> -    int (*enable_device)(struct pci_dev *pdev);
> -    int (*remove_device)(u8 devfn, struct pci_dev *);
> -    int (*assign_device)(struct domain *, u8 devfn, struct pci_dev *);
> +    int (*add_device)(u8 devfn, struct device *);
> +    int (*enable_device)(struct device *dev);
> +    int (*remove_device)(u8 devfn, struct device *);
> +    int (*assign_device)(struct domain *, u8 devfn, struct device *);
>      int (*reassign_device)(struct domain *s, struct domain *t,
> -                        u8 devfn, struct pci_dev *);
> +                           u8 devfn, struct device *);

Please be consistent and either drop the parameter name from all
struct device * instances (my preference), or add one everywhere
(apparently the preference of a some other folks).

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to