Title: [143554] trunk
- Revision
- 143554
- Author
- k...@webkit.org
- Date
- 2013-02-20 19:22:31 -0800 (Wed, 20 Feb 2013)
Log Message
Enable CANVAS_PATH flag
https://bugs.webkit.org/show_bug.cgi?id=108508
Source/WebCore:
Uneviewed attempt to fix Qt minimal build.
* html/canvas/DOMPath.h:
(WebCore::DOMPath::DOMPath):
LayoutTests:
Reviewed by Simon Fraser.
Unreviewed rebaseline after landing patch.
* fast/dom/constructed-objects-prototypes-expected.txt:
Modified Paths
Diff
Modified: trunk/LayoutTests/ChangeLog (143553 => 143554)
--- trunk/LayoutTests/ChangeLog 2013-02-21 02:43:36 UTC (rev 143553)
+++ trunk/LayoutTests/ChangeLog 2013-02-21 03:22:31 UTC (rev 143554)
@@ -1,3 +1,14 @@
+2013-02-20 Dirk Schulze <k...@webkit.org>
+
+ Enable CANVAS_PATH flag
+ https://bugs.webkit.org/show_bug.cgi?id=108508
+
+ Reviewed by Simon Fraser.
+
+ Unreviewed rebaseline after landing patch.
+
+ * fast/dom/constructed-objects-prototypes-expected.txt:
+
2013-02-20 Filip Pizlo <fpi...@apple.com>
DFG inlines Resolves that it doesn't know how to handle correctly
Modified: trunk/LayoutTests/fast/dom/constructed-objects-prototypes-expected.txt (143553 => 143554)
--- trunk/LayoutTests/fast/dom/constructed-objects-prototypes-expected.txt 2013-02-21 02:43:36 UTC (rev 143553)
+++ trunk/LayoutTests/fast/dom/constructed-objects-prototypes-expected.txt 2013-02-21 03:22:31 UTC (rev 143554)
@@ -45,6 +45,8 @@
PASS (new inner.OverflowEvent()).constructor.isInner is true
PASS (new inner.PageTransitionEvent()).isInner is true
PASS (new inner.PageTransitionEvent()).constructor.isInner is true
+PASS (new inner.Path()).isInner is true
+PASS (new inner.Path()).constructor.isInner is true
PASS (new inner.PopStateEvent()).isInner is true
PASS (new inner.PopStateEvent()).constructor.isInner is true
PASS (new inner.ProgressEvent()).isInner is true
Modified: trunk/Source/WebCore/ChangeLog (143553 => 143554)
--- trunk/Source/WebCore/ChangeLog 2013-02-21 02:43:36 UTC (rev 143553)
+++ trunk/Source/WebCore/ChangeLog 2013-02-21 03:22:31 UTC (rev 143554)
@@ -1,3 +1,13 @@
+2013-02-20 Dirk Schulze <k...@webkit.org>
+
+ Enable CANVAS_PATH flag
+ https://bugs.webkit.org/show_bug.cgi?id=108508
+
+ Uneviewed attempt to fix Qt minimal build.
+
+ * html/canvas/DOMPath.h:
+ (WebCore::DOMPath::DOMPath):
+
\2013-02-20 Mark Lam <mark....@apple.com>
Rename DatabaseBackendAsync to DatabaseBackend.
Modified: trunk/Source/WebCore/html/canvas/DOMPath.h (143553 => 143554)
--- trunk/Source/WebCore/html/canvas/DOMPath.h 2013-02-21 02:43:36 UTC (rev 143553)
+++ trunk/Source/WebCore/html/canvas/DOMPath.h 2013-02-21 03:22:31 UTC (rev 143554)
@@ -62,13 +62,15 @@
{
m_path = path->path();
}
-#if ENABLE(SVG)
DOMPath(const String& pathData)
: CanvasPathMethods()
{
+#if ENABLE(SVG)
buildPathFromString(pathData, m_path);
+#else
+ UNUSED_PARAM(pathData);
+#endif
}
-#endif
};
}
#endif
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes