Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: b0e29729124b38c0335dc586deac55a071c025eb
https://github.com/WebKit/WebKit/commit/b0e29729124b38c0335dc586deac55a071c025eb
Author: Kimmo Kinnunen <[email protected]>
Date: 2026-09-22 (Tue, 22 Sep 2026)
Changed paths:
M Source/WebCore/Modules/WebGPU/Implementation/WebGPUAdapterImpl.cpp
M Source/WebGPU/WebGPU/Adapter.h
M Source/WebGPU/WebGPU/Adapter.mm
M Source/WebGPU/WebGPU/WebGPU.h
Log Message:
-----------
WebGPU: Rename WGPUAdapterProperties to WGPUAdapterInfo
https://bugs.webkit.org/show_bug.cgi?id=324800
rdar://188062368
Reviewed by Mike Wyrzykowski.
Rename WGPUAdapterProperties to WGPUAdapterInfo. This makes the symbol
match the standard webgpu.h. Since WebGPU.h arbitrarily mimics webgpu.h,
there is no benefit in deviating.
This is work towards being able to use WebGPU.h in ANGLE/WebGPU that
uses the standard webgpu.h interface.
* Source/WebCore/Modules/WebGPU/Implementation/WebGPUAdapterImpl.cpp:
(WebCore::WebGPU::adapterName):
(WebCore::WebGPU::isFallbackAdapter):
(WebCore::WebGPU::subgroupMinSize):
(WebCore::WebGPU::subgroupMaxSize):
* Source/WebGPU/WebGPU/Adapter.h:
* Source/WebGPU/WebGPU/Adapter.mm:
(WebGPU::Adapter::getInfo):
(wgpuAdapterGetInfo):
(WebGPU::Adapter::getProperties): Deleted.
(wgpuAdapterGetProperties): Deleted.
* Source/WebGPU/WebGPU/WebGPU.h:
Canonical link: https://commits.webkit.org/321670@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications