Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 62692012c98a7e0fe29e6f44d5b059c7f5ff66f9
      
https://github.com/WebKit/WebKit/commit/62692012c98a7e0fe29e6f44d5b059c7f5ff66f9
  Author: Dan Hecht <[email protected]>
  Date:   2026-08-13 (Thu, 13 Aug 2026)

  Changed paths:
    M Source/JavaScriptCore/API/JSHeapFinalizerPrivate.cpp
    M Source/JavaScriptCore/CMakeLists.txt
    M Source/JavaScriptCore/JavaScriptCore.xcodeproj/project.pbxproj
    M Source/JavaScriptCore/Sources.txt
    A Source/JavaScriptCore/heap/GCCompletionCallback.cpp
    A Source/JavaScriptCore/heap/GCCompletionCallback.h
    M Source/JavaScriptCore/heap/Heap.cpp
    M Source/JavaScriptCore/heap/Heap.h
    R Source/JavaScriptCore/heap/HeapFinalizerCallback.cpp
    R Source/JavaScriptCore/heap/HeapFinalizerCallback.h
    M Source/WebCore/WebCorePrefix.h

  Log Message:
  -----------
  [JSC] Rename HeapFinalizerCallback to GCCompletionCallback
https://bugs.webkit.org/show_bug.cgi?id=321690
rdar://184834345

Reviewed by Vassili Bykov.

This is a once-per-GC embedder callback, not a finalizer: it is passed no object
and runs at the end of every collection. It is the internal half of
JSContextGroupAddHeapFinalizer.

    HeapFinalizerCallback           -> GCCompletionCallback
    Heap::addHeapFinalizerCallback  -> Heap::addGCCompletionCallback
    Heap::removeHeapFinalizerCallback
                                    -> Heap::removeGCCompletionCallback
    m_heapFinalizerCallbacks        -> m_gcCompletionCallbacks

The exported C entry points JSContextGroupAddHeapFinalizer and
JSContextGroupRemoveHeapFinalizer keep their names for binary compatibility.

No behavior change.

* Source/JavaScriptCore/API/JSHeapFinalizerPrivate.cpp:
(JSContextGroupAddHeapFinalizer):
(JSContextGroupRemoveHeapFinalizer):
* Source/JavaScriptCore/CMakeLists.txt:
* Source/JavaScriptCore/JavaScriptCore.xcodeproj/project.pbxproj:
* Source/JavaScriptCore/Sources.txt:
* Source/JavaScriptCore/heap/GCCompletionCallback.cpp: Renamed from 
Source/JavaScriptCore/heap/HeapFinalizerCallback.cpp.
(JSC::GCCompletionCallback::dump const):
(JSC::GCCompletionCallback::run const):
* Source/JavaScriptCore/heap/GCCompletionCallback.h: Renamed from 
Source/JavaScriptCore/heap/HeapFinalizerCallback.h.
(JSC::GCCompletionCallback::GCCompletionCallback):
(JSC::GCCompletionCallback::operator bool const):
* Source/JavaScriptCore/heap/Heap.cpp:
(JSC::Heap::clearConcurrentRetainedDataIfPossible):
* Source/JavaScriptCore/heap/Heap.h:
* Source/WebCore/WebCorePrefix.h:

Canonical link: https://commits.webkit.org/319140@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to