Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: a9b9cd9fbbe9a7d28e97d50bd6f53d3dcb2697ff
      
https://github.com/WebKit/WebKit/commit/a9b9cd9fbbe9a7d28e97d50bd6f53d3dcb2697ff
  Author: Fady Farag <[email protected]>
  Date:   2026-08-12 (Wed, 12 Aug 2026)

  Changed paths:
    M Source/WebCore/Modules/webaudio/MediaElementAudioSourceNode.cpp
    M Source/WebCore/Modules/webaudio/MediaStreamAudioSourceNode.cpp
    M Source/WebCore/editing/MarkupAccumulator.cpp
    M Source/WebCore/platform/audio/MultiChannelResampler.cpp

  Log Message:
  -----------
  Use C++14 lambdas instead of `std::bind()` in WebCore
https://bugs.webkit.org/show_bug.cgi?id=321560
rdar://184667562

Reviewed by Ryosuke Niwa.

This mainly improves code readability. Lambdas also inline better.
This also increases Clang static analysis coverage since captures are
visible to SaferCPP checkers.

* Source/WebCore/Modules/webaudio/MediaElementAudioSourceNode.cpp:
(WebCore::MediaElementAudioSourceNode::updateResamplerIfNeeded):
* Source/WebCore/Modules/webaudio/MediaStreamAudioSourceNode.cpp:
(WebCore::MediaStreamAudioSourceNode::setFormat):
* Source/WebCore/editing/MarkupAccumulator.cpp:
(WebCore::MarkupAccumulator::shouldExcludeElement):
* Source/WebCore/platform/audio/MultiChannelResampler.cpp:
(WebCore::MultiChannelResampler::MultiChannelResampler):

Canonical link: https://commits.webkit.org/319027@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to