Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: b995ec5503b1137d52b9c3b0225958cdf42c1ac1
      
https://github.com/WebKit/WebKit/commit/b995ec5503b1137d52b9c3b0225958cdf42c1ac1
  Author: Carlos Garcia Campos <[email protected]>
  Date:   2026-07-22 (Wed, 22 Jul 2026)

  Changed paths:
    M Source/WebCore/rendering/RenderLayer.cpp
    M Source/WebCore/rendering/RenderLayer.h

  Log Message:
  -----------
  Simplify RenderLayer::calculateLayerBounds() to compute the local clip rect
https://bugs.webkit.org/show_bug.cgi?id=319986

Reviewed by Simon Fraser.

RenderLayer::localClipRect() is public, but only used by
RenderLayer::calculateLayerBounds() so it could be simplified by making
it a simple lambda inside calculateLayerBounds(). This way we don't need
the LocalClipRectMode enum nor the clipExceedsBounds out parameter.

No new tests since this shouldn't change the behavior.

* Source/WebCore/rendering/RenderLayer.cpp:
(WebCore::RenderLayer::calculateClipRects const):
* Source/WebCore/rendering/RenderLayer.h:

Canonical link: https://commits.webkit.org/317721@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to