Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: cd0d2eee8a72a46efa4993c6c40e730768bae0db
      
https://github.com/WebKit/WebKit/commit/cd0d2eee8a72a46efa4993c6c40e730768bae0db
  Author: Ahmad Saleem <[email protected]>
  Date:   2026-07-22 (Wed, 22 Jul 2026)

  Changed paths:
    M Source/WTF/wtf/UniqueRef.h
    M Source/WTF/wtf/WeakPtr.h

  Log Message:
  -----------
  WeakPtr::is()/UniqueRef::is() const variadic overloads should be named isAnyOf
https://bugs.webkit.org/show_bug.cgi?id=319815
rdar://182714057

Reviewed by Sam Weinig.

The const variadic overloads in WeakPtr.h and UniqueRef.h were
mistakenly named is() instead of isAnyOf(), colliding with the
const single-argument is() overload and leaving isAnyOf() without
a const overload for these two types. Ref.h, RefPtr.h, CheckedPtr.h,
and CheckedRef.h all name this overload isAnyOf() correctly.

* Source/WTF/wtf/UniqueRef.h:
(WTF::isAnyOf):
* Source/WTF/wtf/WeakPtr.h:
(WTF::isAnyOf):

Canonical link: https://commits.webkit.org/317716@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to