Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 2ec7fdde9d38c50157326629df576514451468b4
      
https://github.com/WebKit/WebKit/commit/2ec7fdde9d38c50157326629df576514451468b4
  Author: Brady Eidson <[email protected]>
  Date:   2026-07-22 (Wed, 22 Jul 2026)

  Changed paths:
    M Source/WebKit/UIProcess/API/Cocoa/WKJSHandle.h
    M Source/WebKit/UIProcess/API/Cocoa/WKJSHandle.mm
    M Source/WebKit/UIProcess/API/Cocoa/_WKJSHandle.h

  Log Message:
  -----------
  Rename WKJSHandle.frame to WKJSHandle.sourceFrame
rdar://182612413
https://bugs.webkit.org/show_bug.cgi?id=319922

Reviewed by Alex Christensen.

There's already many `.frame` properties on various classes on Cocoa platforms, 
most of which are NS/CGRect.
This new property is a bit confusing for devs cognitively, and also trips up 
tooling.

Let's rename to something that already has WebKit precedent.

* Source/WebKit/UIProcess/API/Cocoa/WKJSHandle.h:
* Source/WebKit/UIProcess/API/Cocoa/WKJSHandle.mm:
(-[WKJSHandle sourceFrame]):
(-[_WKJSHandle frame]):
(-[WKJSHandle frame]): Deleted.
* Source/WebKit/UIProcess/API/Cocoa/_WKJSHandle.h:

Canonical link: https://commits.webkit.org/317714@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to