Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 4ae3114d45cb72cca15bb119fc3e7756007e7ea4
      
https://github.com/WebKit/WebKit/commit/4ae3114d45cb72cca15bb119fc3e7756007e7ea4
  Author: Fady Farag <[email protected]>
  Date:   2026-07-22 (Wed, 22 Jul 2026)

  Changed paths:
    M Source/WebCore/css/parser/CSSPropertyParserConsumer+Transform.cpp
    M Source/WebCore/css/typedom/CSSNumericValue.cpp
    M Source/WebCore/dom/Document.cpp
    M Source/WebCore/dom/Node.cpp
    M Source/WebCore/dom/ScriptExecutionContext.cpp
    M Source/WebCore/rendering/LogicalSelectionOffsetCachesInlines.h
    M Source/WebCore/rendering/RenderBlockFlow.cpp
    M Source/WebCore/rendering/RenderBoxModelObject.cpp
    M Source/WebCore/rendering/RenderLayer.cpp
    M Source/WebCore/rendering/RenderLayerCompositor.cpp
    M Source/WebCore/rendering/RenderLayoutState.cpp
    M Source/WebCore/rendering/RenderObject.cpp
    M Source/WebCore/rendering/RenderTreeAsText.cpp
    M Source/WebCore/rendering/shapes/ShapeInterval.h
    M Source/WebCore/rendering/svg/RenderSVGInlineText.cpp

  Log Message:
  -----------
  Reduce further unnecessary usage of ternary operator in WebCore
https://bugs.webkit.org/show_bug.cgi?id=319933
rdar://182856553

Reviewed by Chris Dumez.

This improves readability and enforces more idiomatic C++ by resorting to
equivalent binary boolean operations.

* Source/WebCore/css/parser/CSSPropertyParserConsumer+Transform.cpp:
(WebCore::CSSPropertyParserHelpers::consumeRotate):
* Source/WebCore/css/typedom/CSSNumericValue.cpp:
(WebCore::operationOnValuesOfSameUnit):
* Source/WebCore/dom/Document.cpp:
(WebCore::Document::hasTouchEventHandlers const):
* Source/WebCore/dom/Node.cpp:
(WebCore::Node::canStartSelection const):
* Source/WebCore/dom/ScriptExecutionContext.cpp:
(WebCore::ScriptExecutionContext::allowsMediaDevices const):
* Source/WebCore/rendering/LogicalSelectionOffsetCachesInlines.h:
(WebCore::LogicalSelectionOffsetCaches::ContainingBlockInfo::setBlock):
* Source/WebCore/rendering/RenderBlockFlow.cpp:
(WebCore::RenderBlockFlow::MarginInfo::MarginInfo):
(WebCore::RenderBlockFlow::styleWillChange):
(WebCore::RenderBlockFlow::hasContentfulInlineOrBlockLine const):
(WebCore::RenderBlockFlow::hasContentfulInlineLine const):
* Source/WebCore/rendering/RenderBoxModelObject.cpp:
(WebCore::RenderBoxModelObject::adjustedPositionRelativeToOffsetParent const):
* Source/WebCore/rendering/RenderLayer.cpp:
(WebCore::RenderLayer::referenceBoxRectForClipPath const):
(WebCore::RenderLayer::calculateClipRects const):
* Source/WebCore/rendering/RenderLayerCompositor.cpp:
(WebCore::RenderLayerCompositor::updateCompositingLayers):
* Source/WebCore/rendering/RenderLayoutState.cpp:
(WebCore::RenderLayoutState::computeOffsets):
* Source/WebCore/rendering/RenderObject.cpp:
(WebCore::RenderObject::canUpdateSelectionOnRootLineBoxes):
* Source/WebCore/rendering/RenderTreeAsText.cpp:
(WebCore::writeLayers):
* Source/WebCore/rendering/shapes/ShapeInterval.h:
(WebCore::ShapeInterval::isEmpty const):
* Source/WebCore/rendering/svg/RenderSVGInlineText.cpp:
(WebCore::RenderSVGInlineText::styleDidChange):

Canonical link: https://commits.webkit.org/317710@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to