Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 6a6bb4258c586afe702c77cda962322792dc5e86
https://github.com/WebKit/WebKit/commit/6a6bb4258c586afe702c77cda962322792dc5e86
Author: Alan Baradlay <[email protected]>
Date: 2026-07-01 (Wed, 01 Jul 2026)
Changed paths:
M Source/WebCore/dom/Element.cpp
M Source/WebCore/editing/EditorCommand.cpp
M Source/WebCore/html/MediaElementSession.cpp
M Source/WebCore/inspector/InspectorOverlay.cpp
M Source/WebCore/page/SpatialNavigation.cpp
M Source/WebCore/rendering/RenderBlock.cpp
M Source/WebCore/rendering/RenderBlockFlow.cpp
M Source/WebCore/rendering/RenderBox.cpp
M Source/WebCore/rendering/RenderBox.h
M Source/WebCore/rendering/RenderBoxInlines.h
M Source/WebCore/rendering/RenderFragmentContainer.cpp
M Source/WebCore/rendering/RenderGrid.cpp
M Source/WebCore/rendering/RenderLayer.cpp
M Source/WebCore/rendering/RenderLayerScrollableArea.cpp
M Source/WebCore/rendering/RenderListBox.cpp
M Source/WebCore/rendering/RenderMarquee.cpp
M Source/WebCore/rendering/RenderReplaced.cpp
M Source/WebCore/rendering/RenderTextControlSingleLine.cpp
M Source/WebCore/rendering/RenderTreeAsText.cpp
M Source/WebCore/rendering/RenderView.cpp
M Source/WebCore/rendering/ScrollbarUpdateScope.cpp
M Source/WebKitLegacy/mac/WebCoreSupport/WebContextMenuClient.mm
Log Message:
-----------
[cleanup] Remove the DOM-flavored client* API from RenderBox
https://bugs.webkit.org/show_bug.cgi?id=318042
<rdar://problem/181017761>
Reviewed by Antti Koivisto.
clientWidth/clientHeight/clientLeft/clientTop and clientBoxRect are DOM concepts
(Element.clientWidth and friends) that on RenderBox were just thin aliases over
layout geometry: clientWidth is paddingBoxWidth, clientLeft is borderLeft, and
clientBoxRect is a padding-box-sized rect placed at the border-box origin.
Remove them and point every caller, including the DOM Element::client*
implementations, straight at paddingBox*/border*. Add
paddingBoxLogicalWidth/Height/Bottom to mirror contentBoxLogical* for the former
clientLogical* callers, and rename flippedClientBoxRect to flippedPaddingBoxRect
since it returns the flipped padding box used for overflow rectangles, not a DOM
rect.
No behavior change.
* Source/WebCore/dom/Element.cpp:
(WebCore::Element::clientLeft):
(WebCore::Element::clientTop):
(WebCore::Element::clientWidth):
(WebCore::Element::clientHeight):
* Source/WebCore/editing/EditorCommand.cpp:
(WebCore::verticalScrollDistance):
* Source/WebCore/html/MediaElementSession.cpp:
(WebCore::isElementLargeRelativeToMainFrame):
(WebCore::isElementLargeEnoughForMainContent):
* Source/WebCore/inspector/InspectorOverlay.cpp:
(WebCore::buildRendererHighlight):
* Source/WebCore/page/SpatialNavigation.cpp:
(WebCore::scrollInDirection):
(WebCore::canScrollInDirection):
* Source/WebCore/rendering/RenderBlock.cpp:
(WebCore::RenderBlock::simplifiedLayout):
(WebCore::RenderBlock::layoutOverflowLogicalBottom):
* Source/WebCore/rendering/RenderBlockFlow.cpp:
(WebCore::RenderBlockFlow::layoutBlock):
* Source/WebCore/rendering/RenderBox.cpp:
(WebCore::RenderBox::scrollWidth const):
(WebCore::RenderBox::scrollHeight const):
(WebCore::absoluteInteractionBounds):
(WebCore::RenderBox::containingBlockRangeForPositioned const):
(WebCore::RenderBox::hasLayoutOverflow const):
(WebCore::RenderBox::clampToAllowedLayoutOverflow):
(WebCore::RenderBox::addLayoutOverflow):
(WebCore::RenderBox::addMarginBoxOverflow):
(WebCore::RenderBox::ensureOverflow):
(WebCore::RenderBox::flippedPaddingBoxRect const):
(WebCore::RenderBox::clientWidth const): Deleted.
(WebCore::RenderBox::clientHeight const): Deleted.
(WebCore::RenderBox::flippedClientBoxRect const): Deleted.
* Source/WebCore/rendering/RenderBox.h:
(WebCore::RenderBox::layoutOverflowRect const):
(WebCore::RenderBox::hasHorizontalLayoutOverflow const):
(WebCore::RenderBox::hasVerticalLayoutOverflow const):
* Source/WebCore/rendering/RenderBoxInlines.h:
(WebCore::RenderBox::marginBoxLogicalHeight const):
(WebCore::RenderBox::paddingBoxLogicalBottom const):
(WebCore::RenderBox::paddingBoxLogicalHeight const):
(WebCore::RenderBox::paddingBoxLogicalWidth const):
(WebCore::RenderBox::flippedContentBoxRect const):
(WebCore::RenderBox::scrollablePaddingAreaOverflowRect const):
(WebCore::RenderBox::clientBoxRect const): Deleted.
(WebCore::RenderBox::clientLeft const): Deleted.
(WebCore::RenderBox::clientLogicalBottom const): Deleted.
(WebCore::RenderBox::clientLogicalHeight const): Deleted.
(WebCore::RenderBox::clientLogicalWidth const): Deleted.
(WebCore::RenderBox::clientTop const): Deleted.
* Source/WebCore/rendering/RenderFragmentContainer.cpp:
(WebCore::RenderFragmentContainer::computedLayoutOverflowRectForBox const):
* Source/WebCore/rendering/RenderGrid.cpp:
(WebCore::RenderGrid::gridAreaRangeForOutOfFlow const):
(WebCore::RenderGrid::translateRTLCoordinate const):
* Source/WebCore/rendering/RenderLayer.cpp:
(WebCore::RenderLayer::visibleSize const):
* Source/WebCore/rendering/RenderLayerScrollableArea.cpp:
(WebCore::RenderLayerScrollableArea::hasHorizontalOverflow const):
(WebCore::RenderLayerScrollableArea::hasVerticalOverflow const):
(WebCore::RenderLayerScrollableArea::updateScrollbarSteps):
* Source/WebCore/rendering/RenderListBox.cpp:
(WebCore::RenderListBox::scrollWidth const):
(WebCore::RenderListBox::scrollHeight const):
* Source/WebCore/rendering/RenderMarquee.cpp:
(WebCore::RenderMarquee::computePosition):
(WebCore::RenderMarquee::timerFired):
* Source/WebCore/rendering/RenderReplaced.cpp:
(WebCore::RenderReplaced::computeConstrainedLogicalWidth const):
* Source/WebCore/rendering/RenderTextControlSingleLine.cpp:
(WebCore::RenderTextControlSingleLine::scrollWidth const):
(WebCore::RenderTextControlSingleLine::scrollHeight const):
* Source/WebCore/rendering/RenderTreeAsText.cpp:
(WebCore::writeLayerUsingGeometryType):
* Source/WebCore/rendering/RenderView.cpp:
(WebCore::RenderView::clientLogicalWidthForFixedPosition const):
(WebCore::RenderView::clientLogicalHeightForFixedPosition const):
* Source/WebCore/rendering/ScrollbarUpdateScope.cpp:
(WebCore::ScrollbarUpdateScope::~ScrollbarUpdateScope):
* Source/WebKitLegacy/mac/WebCoreSupport/WebContextMenuClient.mm:
(WebContextMenuClient::clientFloatRectForNode const):
Canonical link: https://commits.webkit.org/316255@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications