Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 18516999f3aaadfb069eb833799e73fe8719815c
https://github.com/WebKit/WebKit/commit/18516999f3aaadfb069eb833799e73fe8719815c
Author: Phipson Lee <[email protected]>
Date: 2026-06-22 (Mon, 22 Jun 2026)
Changed paths:
M Source/WebKit/UIProcess/API/ios/WKWebViewIOS.mm
Log Message:
-----------
Refactor _endLiveResize to separate Responsive and Unresponsive Live-resize
Updates
https://bugs.webkit.org/show_bug.cgi?id=317000
rdar://179498356
Reviewed by Abrar Rahman Protyasha.
This PR separates the logic for the responsive live resize for _endLiveResize
to make the code more readable and maintainable. The underlying logic should be
the same with no changes.
* Source/WebKit/UIProcess/API/ios/WKWebViewIOS.mm:
(-[WKWebView _endLiveResizeWithResponsiveRelayout]):
Add an internal function for the end live resize flow when we are responsively
updating
web view layout
(-[WKWebView _endLiveResizeDefault]):
Add an internal function for end live resize behavior in the general case
without responsive
relayout
(-[WKWebView _endLiveResize]):
Update the function to call the above two internal functions rather than
directly adding
if-defs into the function.
Canonical link: https://commits.webkit.org/315636@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications