Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: f5478d9ee0c44575582ea6cb20319ef98c734a2c
      
https://github.com/WebKit/WebKit/commit/f5478d9ee0c44575582ea6cb20319ef98c734a2c
  Author: Geoffrey Garen <gga...@apple.com>
  Date:   2024-11-03 (Sun, 03 Nov 2024)

  Changed paths:
    M Source/WTF/wtf/IndexedRange.h

  Log Message:
  -----------
  Build fix for some Apple internal bots
https://bugs.webkit.org/show_bug.cgi?id=282513
rdar://139160864

Unreviewed, build fix.

Some versions of libc++ use an unqualified call to 'begin()' when e.g.
instantiating a span.

In some contexts that creates a name conflict with WTF::begin because of
argument-dependent lookup.

Rename begin/end to boundsCheckedBegin/boundsCheckedEnd to fix this.

* Source/WTF/wtf/IndexedRange.h:
(WTF::boundsCheckedBegin):
(WTF::boundsCheckedEnd):
(WTF::IndexedRange::IndexedRange):
(WTF::begin): Deleted.
(WTF::end): Deleted.

Canonical link: https://commits.webkit.org/286062@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to