Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 241cc4bba9ccc2218fc30b9ee65a24dd7636daef
      
https://github.com/WebKit/WebKit/commit/241cc4bba9ccc2218fc30b9ee65a24dd7636daef
  Author: Abrar Rahman Protyasha <a_protya...@apple.com>
  Date:   2024-03-18 (Mon, 18 Mar 2024)

  Changed paths:
    M 
Source/WebKit/WebProcess/Plugins/PDF/UnifiedPDF/PDFDataDetectorOverlayController.mm
    M Source/WebKit/WebProcess/Plugins/PDF/UnifiedPDF/UnifiedPDFPlugin.h
    M Source/WebKit/WebProcess/Plugins/PDF/UnifiedPDF/UnifiedPDFPlugin.mm

  Log Message:
  -----------
  [UnifiedPDF] Refactor selectionBoundsAcrossDocument() to accept a target 
coordinate space
https://bugs.webkit.org/show_bug.cgi?id=271181
rdar://124969883

Reviewed by Sammy Gill.

This patch is a small refactor of the selectionBoundsAcrossDocument()
family of methods to some review feedback from 276239@main. This method
now accepts a target coordinate space to represent its results in. I've
also taken the liberty to rename it to `boundsForSelection`, since the
target coordinate space needn't be implicit in the name anymore.

* 
Source/WebKit/WebProcess/Plugins/PDF/UnifiedPDF/PDFDataDetectorOverlayController.mm:
(WebKit::PDFDataDetectorOverlayController::didInvalidateHighlightOverlayRects):
* Source/WebKit/WebProcess/Plugins/PDF/UnifiedPDF/UnifiedPDFPlugin.h:
* Source/WebKit/WebProcess/Plugins/PDF/UnifiedPDF/UnifiedPDFPlugin.mm:
(WebKit::UnifiedPDFPlugin::boundsForSelection const):
(WebKit::UnifiedPDFPlugin::repaintOnSelectionActiveStateChangeIfNeeded):
(WebKit::UnifiedPDFPlugin::setCurrentSelection):
(WebKit::UnifiedPDFPlugin::selectionBoundsAcrossDocument const): Deleted.
(WebKit::UnifiedPDFPlugin::selectionBoundsAcrossDocumentInContentSpace const): 
Deleted.

Canonical link: https://commits.webkit.org/276321@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to