I have been creating a small Tapestry 5 application in order to see how the framework works and how T5 applications differ from JSP/Servlet applications.
One thing that I did as part of this project was to create an ObjectProvider implementation (it is very simple, I admit) which allows one to @Inject http://db4o.com Db4o ObjectServers (after the app's module builder has added it to MasterObjectProvider). I would like to suggest that the "contribute...()" methods be renamed to "configure...()" because the current names are confusing. For example, contributeMasterObjectProvider does not actually contribute a MasterObjectProvider; instead, the method is used to add ObjectProviders, which essentially means configuring the MasterObjectProvider service. Maybe the method should even be called "configureMasterObjectProviderService" in order to clarify this even further. Hopefully other users will comment on this informal proposal as it would be a somewhat complicated change due to its use almost everywhere. -- View this message in context: http://www.nabble.com/T5%3A-Should-%22contribute...%28%29%22-be-%22configure...%28%29%22-or-%22configure...Service%28%29%22--tf4075108.html#a11581727 Sent from the Tapestry - User mailing list archive at Nabble.com. --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]