The method name should now be contributeRequestHandler().
On 3/21/07, Bogdan Calmac <[EMAIL PROTECTED]> wrote:
One of the methods marked with @Contribute (see below) was a timing filter which would display in the console the duration of each request. After removing the @Contribute annotation (which is not available in 5.0.3) the filter is no longer called. So, is there another annotations to contribute services or the naming convention used here is inaccurate? Since generally in tapestry you can use either annotations or naming convention, I think it would be good to keep the same paradigm here. @Contribute("tapestry.RequestHandler") public void contributeRequestFilters(OrderedConfiguration<RequestFilter> configuration, @InjectService("TimingFilter") RequestFilter filter) { // Each contribution to an ordered configuration has a name, which will be qualified with // the module's id. Here, the fully qualified id will be "app.Timing". When necessary, you may // set constraints to precisely control the invocation order of the contributed filter // within the pipeline. configuration.add("Timing", filter); } --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
-- Howard M. Lewis Ship TWD Consulting, Inc. Independent J2EE / Open-Source Java Consultant Creator and PMC Chair, Apache Tapestry Creator, Apache HiveMind Professional Tapestry training, mentoring, support and project work. http://howardlewisship.com --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]