I don't see a reason to dump it into DataObjectUtils since we don't have to. :-) I was thinking about something in CayenneDataObject, but that doesn't seem quite right, either for the same reasoning (although might be more convenient on users).
As to not having a fetch method in a query class, I'm fine with that. I was asking for opinions, after all. Thanks, /dev/mrg On 6/4/07, Andrus Adamchik <[EMAIL PROTECTED]> wrote:
On Jun 4, 2007, at 5:06 PM, Michael Gentry wrote: > Putting it in DataObjectUtils doesn't seem the right place to me. > Using your example: > > DataObjectUtils.objectForQuery(...) > > returns a DataObject (which makes sense to me, being packaged in > DataObjectUtils). Something that returns an int, which can't even be > converted into a DataObject, doesn't feel like it should be in > DataObjectUtils. I agree that DataObjectUtils becoming a kitchen sink is bad, and "DataObjectUtils" name is a bit obsolete anyways, considering that "Persistent" is the interface Cayenne stack is dealing with. So DataObjectUtils class itself needs some redesign (split QueryUtils out of it or something?) My other point about not adding fetch methods to the query classes is still valid though. So we can either push for DataObjectUtils redesign now, or use it as a kitchen sink one more time :-) Andrus