The second one is more readable. The third is unnecessary. The first works just fine. It just depends on how readable you want to make your code for others. I always take the time to put values into their own variables so I can point at them in the debugger and see their current values in the stepper. So:
put item 4 of line x of tList into tValue add tValue to tRunningTotal seems to me to be more readable, at the expense of a little extra typing. Bob S > On Apr 2, 2018, at 14:48 , Knapp Martin via use-livecode > <[email protected]> wrote: > > I have a tab delimited list where item 4 is a number and I'm adding things > up. What is considered best practice when doing this? > > add item 4 of line x of tList to tRunningTotal > or > add (item 4 of line x of tList) to tRunningTotal > or > add value(item 4 of line x of tList) to tRunningTotal > > Marty > _______________________________________________ > use-livecode mailing list > [email protected] > Please visit this url to subscribe, unsubscribe and manage your subscription > preferences: > http://lists.runrev.com/mailman/listinfo/use-livecode _______________________________________________ use-livecode mailing list [email protected] Please visit this url to subscribe, unsubscribe and manage your subscription preferences: http://lists.runrev.com/mailman/listinfo/use-livecode
