On 19-09-2012 17:19, Scott Wood wrote:
On 09/19/2012 06:25:25 AM, José Miguel Gonçalves wrote:
NAND Flash driver with HW ECC for the S3C24XX SoCs.
Currently it only supports SLC NAND chips.
Signed-off-by: José Miguel Gonçalves <jose.goncal...@inov.pt>
---
Changes for v2:
- Coding style cleanup
- Use of clrsetbits_le32()
- Use of register bit macros instead of magic numbers
Changes for v3:
- Removed magic numbers
- Removed a macro to declare a void printf()
- Replaced one printf() with a puts()
Changes for v4:
- Coding style cleanup
- Use of a struct to store chip private data
- Replaced u_long by u32
- Replaced u_char by uint8_t
- Added error message in s3c_nand_select_chip()
- Optimization of s3c_nand_hwcontrol()
---
drivers/mtd/nand/Makefile | 1 +
drivers/mtd/nand/s3c24xx_nand.c | 255 +++++++++++++++++++++++++++++++++++++++
2 files changed, 256 insertions(+)
create mode 100644 drivers/mtd/nand/s3c24xx_nand.c
Acked-by: Scott Wood <scottw...@freescale.com>
+ nand->priv = (void *)&chip_info[chip_n++];
Hmm, I was going to say that the cast could be dropped, but I guess it's because
of the const.
Yes, it's needed because of the declaration of the private struct as const.
It doesn't need to hold up acceptance of the patch, but it'd probably be better
to drop the const instead (more flexible too if additional private data needs to
be declared).
I think a better option would be to drop the const in the struct and set only the
'cs' member to const.
José Gonçalves
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot