While looking through list.h, I saw that the regular list_* helpers (and one of the hlist_* ones) still contain the prefetch() that was removed in linux 14 years ago. It doesn't do anything, but makes the macros harder to read, so get rid of it, and the fallback, no-op definition that they relied on. That requires removing a few uses outside list.h as well.
checkpatch warns about some whitespace issues in list.h, but as I've copied whole kerneldoc+#define blocks directly from the linux kernel, I think it's better to just accept that so that we don't introduce needless diffs. The "macro argument reuse" arguments should also be ignored, as e.g. the "member" arguments are obviously always just bare identifiers, and the "pos" arguments must be assigned to multiple times. Rasmus Villemoes (4): linux/list.h: drop use of prefetch() treewide: drop no-op prefetch() calls mips: drop unused prefetch code and logic linux/list.h: drop fallback definition of prefetch() arch/mips/include/asm/processor.h | 16 ----- drivers/net/mvpp2.c | 1 - drivers/net/octeontx/nicvf_main.c | 2 - drivers/usb/gadget/at91_udc.c | 1 - drivers/usb/musb-new/musb_core.c | 2 - include/linux/list.h | 104 +++++++++++++++++------------- 6 files changed, 59 insertions(+), 67 deletions(-) -- 2.49.0