On Sun, Jan 26, 2025 at 11:43:15AM -0700, Simon Glass wrote: > The size of some malloc() fields has reduced on 64-bit machines, but > the spl_reloc code was not updated. Fix this to avoid a compiler > warning. > > Also update for the new xPL naming.
There's no naming change made, otherwise: Reviewed-by: Tom Rini <tr...@konsulko.com> > > Signed-off-by: Simon Glass <s...@chromium.org> > --- > > common/spl/spl_reloc.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/common/spl/spl_reloc.c b/common/spl/spl_reloc.c > index be8349b535b..324b98eaf98 100644 > --- a/common/spl/spl_reloc.c > +++ b/common/spl/spl_reloc.c > @@ -154,7 +154,7 @@ int spl_reloc_jump(struct spl_image_info *image, > spl_jump_to_image_t jump) > rcode_func loader; > int ret; > > - log_debug("malloc usage %lx bytes (%ld KB of %d KB)\n", gd->malloc_ptr, > + log_debug("malloc usage %x bytes (%d KB of %d KB)\n", gd->malloc_ptr, > gd->malloc_ptr / 1024, CONFIG_VAL(SYS_MALLOC_F_LEN) / 1024); > > if (*image->stack_prot != STACK_PROT_VALUE) { > -- > 2.43.0 > -- Tom
signature.asc
Description: PGP signature