Dear matt.waddel, > From: Matt Waddel<matt.wad...@linaro.org> > > These patches add support for the ARM PrimeCell PL180 MultiMedia Interface. > The Versatile Express was the test platform for these changes. > > --- > Change log: > > v2 - Rename patch items to a more descriptive name (ie. mmci -> arm_mmci) > Fixed conflicting fuction call and added prototype to arm_mmci.h "function" > (Note: Patch 1/3 did not change with these corrections) > > Matt Waddel (3): > MMC: Max blocks value adjustable > MMC: Add support for PL180 ARM mmc device > ARMV7: Vexpress: Add MMC support > > board/armltd/vexpress/ca9x4_ct_vxp.c | 9 + > drivers/mmc/Makefile | 1 + > drivers/mmc/arm_mmci.c | 452 > ++++++++++++++++++++++++++++++++++ > drivers/mmc/arm_mmci.h | 183 ++++++++++++++ > drivers/mmc/mmc.c | 19 +- > include/configs/ca9x4_ct_vxp.h | 4 + > 6 files changed, 658 insertions(+), 10 deletions(-) > create mode 100644 drivers/mmc/arm_mmci.c > create mode 100644 drivers/mmc/arm_mmci.h
Sorry, my original comment still holds true for the naming, now the name suggests that this driver is generic to ARM devices, which clearly is not true. Can you list which devices have a MMCI that is covered by this driver? PL180 only? Or a series of PLxxx? It should be possible to find a naming that is more descriptive than "arm". (That such a generic name slipped into the kernel must not imply we have to make the same mistake in u-boot) Best Regards, Reinhard _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot