Hi Pali, On Mon, 1 Aug 2022 at 09:43, Pali Rohár <p...@kernel.org> wrote: > > Currently Makefile produces final mpc85xx image when SPL is not used in > custom file u-boot-with-dtb.bin. It is quite confusing name as build > process produce also intermediate file standard file u-boot-dtb.bin (which > is just intermediate and not bootable). Other platforms use u-boot.bin > (UBOOT_BIN) as standard name for final bootable raw image. > > So change Makefile rules and binman to produce final bootable file for > mpc85xx also into file u-boot.bin. There is just need for mpc85xx to not > define default rule for u-boot.bin then instruct binman (via DTS file) to > store final image into u-boot.bin (instead of u-boot-with-dtb.bin) and > finally rename target u-boot-with-dtb.bin to u-boot.bin. > > With this change are also removed custom Makefile hacks for mpc85xx that it > produced non-standard output file. And also updated documentation. > > Signed-off-by: Pali Rohár <p...@kernel.org> > --- > Makefile | 19 +++++-------------- > arch/powerpc/dts/kmcent2-u-boot.dtsi | 2 +- > arch/powerpc/dts/u-boot.dtsi | 2 +- > board/freescale/p1_p2_rdb_pc/README | 2 +- > board/freescale/p2041rdb/README | 3 --- > board/freescale/t102xrdb/README | 2 +- > board/freescale/t104xrdb/README | 2 +- > board/freescale/t208xqds/README | 2 +- > board/freescale/t208xrdb/README | 2 +- > 9 files changed, 12 insertions(+), 24 deletions(-)
At present u-boot.bin has a very standard meaning - it is U-Boot with the DT. Boards which need something more than that can/should use binman to create a separate file. I certainly agree that u-boot-with-dtb.bin is a terrible name, though. Something more descriptive would be better. But is it possible to drop these SoC-specific rules in the Makefile and just build everything needed in the standard binman rule in the Makefile? Regards, Simon