On 7/2/21 8:36 PM, Simon Glass wrote:
Add a new Kconfig option for EBBR so that the naming is more explicit.
Make it select EFI_LOADER which is required for EBBR to work.

Copy over the same 'default' setting so that there is no change in
which boards enable it.

Signed-off-by: Simon Glass <s...@chromium.org>
---

Changes in v2:
- Split out new patch to create an option for EBBR

  common/Kconfig.boot    | 16 ++++++++++++++++
  lib/efi_loader/Kconfig |  1 -
  2 files changed, 16 insertions(+), 1 deletion(-)

diff --git a/common/Kconfig.boot b/common/Kconfig.boot
index 89a3161f1fa..111032e1202 100644
--- a/common/Kconfig.boot
+++ b/common/Kconfig.boot
@@ -300,6 +300,22 @@ config LEGACY_IMAGE_FORMAT
          loaded. If a board needs the legacy image format support in this
          case, enable it here.

+config EBBR
+       bool "Enable support for Embeeded Boot Base Requirements (EBBR)"
+       select EFI_LOADER
+       default y if !ARM || SYS_CPU = armv7 || SYS_CPU = armv8

This won't work. You cannot have UEFI neither on big-endian systems nor
on any other architecture not mentioned in the UEFI specification.

Why do you want to exclude arm1136 and arm1176?

+       help
+         Enable this to support ARM's EBBR boot method. This bases everything
+         on UEFI protocols.ยด

EBBR is explitely not ARM specific. EBBR is not a boot method but a
subset of the UEFI specification.

+
+         This Embedded Base Boot Requirements (EBBR) specification defines an
+         interface between platform firmware and an operating system that is
+         suitable for embedded platforms. EBBR-compliant platforms present a
+         consistent interface that will boot an EBBR-compliant operating
+         system without any custom tailoring required. For example, an Arm
+         A-class embedded platform will benefit from a standard interface that
+         supports features such as secure boot and firmware update.

Which user will ever have heard of the EBBR specification? Referencing
it in Kconfig will lead to confusion.

This new symbol is redundant. If you think that a better name for
EFI_LOADER is needed, please suggest one.

Best regards

Heinrich

+
  config SUPPORT_RAW_INITRD
        bool "Enable raw initrd images"
        help
diff --git a/lib/efi_loader/Kconfig b/lib/efi_loader/Kconfig
index 466abfed300..bc5fb3f5e03 100644
--- a/lib/efi_loader/Kconfig
+++ b/lib/efi_loader/Kconfig
@@ -10,7 +10,6 @@ config EFI_LOADER
        depends on !EFI_STUB || !X86_64 || EFI_STUB_64BIT
        # We need EFI_STUB_32BIT to be set on x86_32 with EFI_STUB
        depends on !EFI_STUB || !X86 || X86_64 || EFI_STUB_32BIT
-       default y if !ARM || SYS_CPU = armv7 || SYS_CPU = armv8
        select LIB_UUID
        select HAVE_BLOCK_DEVICE
        select REGEX

Reply via email to