Hello Albert,

Albert Aribaud wrote:
> SUMMARY:
> 
> This patchset improves the driver for the Marvell TWSI interface found
> on orion5x and kirkwood SoCs and adds I2C support to the orion5x-based
> ED Mini V2 board. The mvtwsi driver is a complete rewrite, 50% shorter
> in source code lines, 25% smaller in object size, much simpler and way
> faster than the kirkwood_i2c driver it replaces.
> 
> PATCH SET:
> 
> Patch 1 removes dependencies on kirwkood_i2c from suen3, the only
> board that mentioned it. Patch 2 renames the driver from kirkwood_i2c
> to mvtwsi. Patch 3 replaces the old code with the new one. Patch 4
> adds support for I2C in orion5x-based ED Mini V2.
> 
> TESTS:
> 
> This driver has been tested on an ED Mini V2 with basic u-boot i2c
> commands, on an 5C372a RTC and an HT24LC08 1 KB eeprom (read+write).
> 
> HISTORY:
> 
> V1:   Initial submission as an addition rather than a replacement.
> 
> V2:   Fixed copyright line.
>       Made mvtwsi a replacement for kirkwood_i2c.
>       Made patches checkpatch-clean: 0 errors, 0 warnings.
>       Various cosmetic changes.
>       Removed useless i2c_end() function.
> 
> V3:   Reduced line lengths below 78 characters.
>       Removed blank line after function description block comment.
> 
> V4:   Changed CONFIG_I2C_DRIVER_MVTWSI into CONFIG_I2C_MVTWSI.
>       Really fixed copyright line.
>       Added and documented kirkwood support.
>       Shortened extended_slave_address into xtnd_slave_addr.
>       Added explanation on default/init baudrate value.
>       Moved I2C config settings under #ifdef CONFIG_CMD_I2C.
> 
> Albert Aribaud (4):
>   suen3: remove CONFIG_HARD_I2C and related defines
>   i2c: rename kirkwood_i2c to mvtwsi
>   i2c: rewrite mvtwsi, support orion5x and kirkwood
>   edminiv2: add I2C support using mvtwsi driver
> 
>  drivers/i2c/Makefile       |    2 +-
>  drivers/i2c/kirkwood_i2c.c |  496 
> --------------------------------------------
>  drivers/i2c/mvtwsi.c       |  428 ++++++++++++++++++++++++++++++++++++++
>  include/configs/edminiv2.h |   11 +
>  include/configs/km_arm.h   |    8 -
>  5 files changed, 440 insertions(+), 505 deletions(-)
>  delete mode 100644 drivers/i2c/kirkwood_i2c.c
>  create mode 100644 drivers/i2c/mvtwsi.c

applied to u-boot-i2c.git

Thanks!

bye,
Heiko
-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to