Hi Simon, -----"Simon Glass" <s...@chromium.org> schrieb: -----
>Betreff: [PATCH v3 12/29] dm: core: Add basic ACPI support > >ACPI (Advanced Configuration and Power Interface) is a standard for >specifying information about a platform. It is a little like device >tree but the bindings are part of the specification and it supports >an >interpreted bytecode language. > >Driver model does not use ACPI for U-Boot's configuration, but it is >convenient to have it support generation of ACPI tables for passing >to >Linux, etc. > >As a starting point, add an optional set of ACPI operations to each >device. Initially only a single operation is available, to obtain the >ACPI name for the device. More operations are added later. > >Enable ACPI for sandbox to ensure build coverage and so that we can >add >tests. > >Reviewed-by: Bin Meng <bmeng...@gmail.com> >Signed-off-by: Simon Glass <s...@chromium.org> >--- > >Changes in v3: >- Compute ACPI_NAME_MAX from ACPI_NAME_LEN >- Drop 'Intel' from 'Intel ACPI' >- Rename acpi_return_name() to acpi_copy_name() >- Reword commit message to drop the bit about ACPI being complicated >- Use strncpy() instead of strcpy() in acpi_copy_name() > >Changes in v2: >- Move LOGC_ACPI definition to this patch > > drivers/core/Kconfig | 9 ++++++ > drivers/core/Makefile | 1 + > drivers/core/acpi.c | 33 +++++++++++++++++++ > include/dm/acpi.h | 73 >+++++++++++++++++++++++++++++++++++++++++++ > include/dm/device.h | 5 +++ > include/log.h | 2 ++ > 6 files changed, 123 insertions(+) > create mode 100644 drivers/core/acpi.c > create mode 100644 include/dm/acpi.h > Reviewed-by: Wolfgang Wallner <wolfgang.wall...@br-automation.com>