On Fri, 9 Aug 2019 04:15:34 +0000 Peng Fan <peng....@nxp.com> wrote: > i.MX8MQ and i.MX8MM has totally different pll design, so > rename clock to clock_imx8mq. > > Signed-off-by: Peng Fan <peng....@nxp.com> > --- > arch/arm/mach-imx/imx8m/Makefile | 3 ++- > arch/arm/mach-imx/imx8m/{clock.c => clock_imx8mq.c} | 0 > 2 files changed, 2 insertions(+), 1 deletion(-) > rename arch/arm/mach-imx/imx8m/{clock.c => clock_imx8mq.c} (100%) > > diff --git a/arch/arm/mach-imx/imx8m/Makefile > b/arch/arm/mach-imx/imx8m/Makefile index feff4941c1..42a1544c6b 100644 > --- a/arch/arm/mach-imx/imx8m/Makefile > +++ b/arch/arm/mach-imx/imx8m/Makefile > @@ -3,4 +3,5 @@ > # Copyright 2017 NXP > > obj-y += lowlevel_init.o > -obj-y += clock.o clock_slice.o soc.o > +obj-y += clock_slice.o soc.o > +obj-$(CONFIG_IMX8MQ) += clock_imx8mq.o
Shouldn't there be then two CONFIG_ entries? LIke CONFIG_IMX8MM and CONFIG_IMX8MQ? > diff --git a/arch/arm/mach-imx/imx8m/clock.c > b/arch/arm/mach-imx/imx8m/clock_imx8mq.c similarity index 100% > rename from arch/arm/mach-imx/imx8m/clock.c > rename to arch/arm/mach-imx/imx8m/clock_imx8mq.c Best regards, Lukasz Majewski -- DENX Software Engineering GmbH, Managing Director: Wolfgang Denk HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-59 Fax: (+49)-8142-66989-80 Email: lu...@denx.de
pgpiOSE6SiFp5.pgp
Description: OpenPGP digital signature
_______________________________________________ U-Boot mailing list U-Boot@lists.denx.de https://lists.denx.de/listinfo/u-boot