Hi Jagan! Any comments?
On Tue, 2018-04-10 at 14:40 +0300, Eugeniy Paltsev wrote: > sst26wf flash series block protection implementation differs > from other SST series, so add specific implementation > flash_lock/flash_unlock/flash_is_locked functions for sst26wf > flash ICs. > > Signed-off-by: Eugeniy Paltsev <[email protected]> > --- > Changes v4->v5: > * Return EACCES when flash is locked instead of custom define (SF_LOCKED) > * Add SST26_CTL_* prefix to sst27 lock ops enum. > * Move all sst26 code inside of existing CONFIG_SPI_FLASH_SST #ifdef. > > Changes v3->v4: > * Make sst26_process_bpr() and sst26_lock_ctl() functions static. > > Changes v2->v3: > * Move SST26 command defenition to sf_internal.h > * Merge sst26_set_bpr, sst26_clear_bpr and sst26_check_bpr functions > into single sst26_process_bpr function. > * Use SF_UNLOCKED/SF_LOCKED instead of magic numbers in > sst26_lock_ctl() > > Changes v1->v2: > * Use generic defines from linux/sizes.h instead of custom ones. > > diff --git a/drivers/mtd/spi/spi_flash.c b/drivers/mtd/spi/spi_flash.c [snip] -- Eugeniy Paltsev _______________________________________________ U-Boot mailing list [email protected] https://lists.denx.de/listinfo/u-boot

