On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass <s...@chromium.org> wrote: > At present this code is inline. Move it into a function to allow it to > be used elsewhere. > > Signed-off-by: Simon Glass <s...@chromium.org>
> +static int blk_next_free_devnum(enum if_type if_type) > +{ > + int ret; > + > + ret = blk_find_max_devnum(if_type); > + if (ret == -ENODEV) > + return 0; > + else if (ret < 0) Useless 'else'. > + return ret; > + else Ditto. > + return ret + 1; > +} -- With Best Regards, Andy Shevchenko _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de https://lists.denx.de/listinfo/u-boot