Now that both branches of the #if do the same thing, we can unify them.

Signed-off-by: Simon Glass <s...@chromium.org>
---

 common/board_f.c | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

diff --git a/common/board_f.c b/common/board_f.c
index 7feffa4939..e387ca2233 100644
--- a/common/board_f.c
+++ b/common/board_f.c
@@ -843,16 +843,12 @@ static const init_fnc_t init_sequence_f[] = {
 #if defined(CONFIG_BOARD_EARLY_INIT_F)
        board_early_init_f,
 #endif
-       /* TODO: can any of this go into arch_cpu_init()? */
-#if defined(CONFIG_8xx_CPUCLK_DEFAULT)
+#ifdef CONFIG_PPC
        /* get CPU and bus clocks according to the environment variable */
-       get_clocks,
-       init_timebase,
-#elif defined(CONFIG_PPC)
        get_clocks,             /* get CPU and bus clocks (etc.) */
        /* TODO: can we rename this to timer_init()? */
        init_timebase,
-#endif /* CONFIG_8xx_CPUCLK_DEFAULT */
+#endif
 #if defined(CONFIG_ARM) || defined(CONFIG_MIPS) || \
                defined(CONFIG_BLACKFIN) || defined(CONFIG_NDS32) || \
                defined(CONFIG_SH) || defined(CONFIG_SPARC)
-- 
2.12.2.564.g063fe858b8-goog

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to