Commit 82f5279b0cd99a9163d34cfe926d0316d9dc0d37 chose
a very bad way to suppress the KeyStone boards failure.

The root cause was that KeyStone is using the same function name clk_get_rate
as the clk-uclass one, but the probotype is completely different.
So, if both <clk.h> and <config.h> are included from a single file
(drivers/serial/ns16550.c does so), it fails to build.

The function is only used for KeyStone specific files,
so we can rename it to avoid name space conflict.



Masahiro Yamada (3):
  ARM: keystone: remove declaration of unused functions
  ARM: keystone: rename clk_get_rate() to ks_clk_get_rate()
  Revert "ns16650: Make sure we have CONFIG_CLK set before using
    infrastructure"

 arch/arm/include/asm/ti-common/keystone_net.h |  4 ++--
 arch/arm/mach-keystone/clock.c                | 24 ++++++++++++------------
 arch/arm/mach-keystone/cmd_clock.c            |  2 +-
 arch/arm/mach-keystone/include/mach/clock.h   |  4 +---
 drivers/serial/ns16550.c                      |  7 ++-----
 include/clk.h                                 | 25 +++++++++++++------------
 include/configs/ti_armv7_keystone2.h          |  8 ++++----
 7 files changed, 35 insertions(+), 39 deletions(-)

-- 
1.9.1

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to