Hi,

I stumbled across this when fixing the whitespace in the mux setup tables
for various omap platforms.

I don't find it to be a very sustainable way of adding random delays into
the gpio setups. Having it open-coded in a C file is much preferred.

from boards/logicpd/zoom2/zoom2.h:

/* Toggle Reset pin of TL16CP754C device */\
        MUX_VAL(CP(MCBSP4_CLKX),        (IEN  | PTU | EN  | M4)) /* GPIO_152 */\
 udelay(10);\
        MUX_VAL(CP(MCBSP4_CLKX),        (IEN  | PTD | EN  | M4)) /* GPIO_152 */\

Also, it seems like alot of the tables are really pretty common between
boards. Maybe those should be extracted out to a separate base table,
with additional per-board tables to be applied on top?


-Olof
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to