In the latest git, I've just noticed what I guess is a typo in this
code.

void portmux_enable_macb1(unsigned long flags, unsigned long
drive_strength)
{
....
        /* REVISIT: Some pins are probably pure outputs */
        portmux_select_peripheral(PORTMUX_PORT_D, portc_mask,
                        PORTMUX_FUNC_B, PORTMUX_BUSKEEPER);
        portmux_select_peripheral(PORTMUX_PORT_C, portc_mask,
                        PORTMUX_FUNC_B, PORTMUX_BUSKEEPER);
}

Both of these calls use the "portc_mask" variable, whereas the first
call is setting PORTMUX_PORT_D.  Should it be "portd_mask" in the first
call ?

Am I missing something or is this clearly wrong ???

Regards
Mark

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to