I splitted this patch. Only patch 1 is an actual issue while the second patch is something I stumbled upon, and the third is more about housekeeping.
I descieded to ifdef the driver, I think that this is easier to read and does not mix register access style. The function ehci_get_port_speed however don't get a pointer to the usb_ctlr struct and thouse has to work around that. I don't changed the register access style there because of this reason. The third patch is optional and implements Stephen's suggestion to merge the USB headers. I'm not sure wheater Tegra124 would also profit from this merge, if yes, I think then its definitely worth doing it. Stefan Agner (3): usb: tegra: fix USB2 powerdown for Tegra30 and later usb: tegra: fix PHY configuration usb: tegra: combine header file arch/arm/include/asm/arch-tegra/usb.h | 215 ++++++++++++++++++++++++++++++- arch/arm/include/asm/arch-tegra114/usb.h | 156 ---------------------- arch/arm/include/asm/arch-tegra20/usb.h | 155 ---------------------- arch/arm/include/asm/arch-tegra30/usb.h | 168 ------------------------ board/nvidia/common/board.c | 1 - drivers/usb/host/ehci-tegra.c | 28 +++- 6 files changed, 238 insertions(+), 485 deletions(-) delete mode 100644 arch/arm/include/asm/arch-tegra114/usb.h delete mode 100644 arch/arm/include/asm/arch-tegra20/usb.h delete mode 100644 arch/arm/include/asm/arch-tegra30/usb.h -- 1.8.5.4 _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot