Hi,

On 11/08/2013 10:27 AM, Rajeshwari Birje wrote:
Hi,


On Fri, Nov 8, 2013 at 2:33 PM, Przemyslaw Marczak
<p.marc...@samsung.com> wrote:
Hi,


On 11/08/2013 09:37 AM, Rajeshwari Birje wrote:

Hi Przemyslaw

On Fri, Nov 8, 2013 at 1:43 PM, Przemyslaw Marczak
<p.marc...@samsung.com> wrote:

Hello Rajeshwari,


On 10/29/2013 08:23 AM, Rajeshwari S Shinde wrote:


Create a common board.c file for all functions which are common across
all EXYNOS5 platforms.

exynos_init function is provided for platform specific code.

Signed-off-by: Rajeshwari S Shinde <rajeshwar...@samsung.com>
Acked-by: Simon Glass <s...@chromium.org>
---
Changes in V2:
          - None
Changes in V3:
          - None
Changes in V4:
          - Added check for the compilation of MAX77686 pmic.
Changes in V5:--
Regards,
Rajeshwari Shind
          - Moved board_eth_init and board_mmc_init in case of
          device tree support
Changes in V6:
          - None.
    arch/arm/include/asm/arch-exynos/board.h |  17 ++
    board/samsung/common/Makefile            |   4 +
    board/samsung/common/board.c             | 405
+++++++++++++++++++++++++++++++
    board/samsung/smdk5250/exynos5-dt.c      | 361
+--------------------------
    board/samsung/smdk5250/smdk5250.c        | 182 +-------------
    include/configs/exynos5250-dt.h          |   2 +
    6 files changed, 435 insertions(+), 536 deletions(-)
    create mode 100644 arch/arm/include/asm/arch-exynos/board.h
    create mode 100644 board/samsung/common/board.c


The name of exynos5 common file can't be just "board.c" since it is
common
only for Exynos5 boards and is placed in Samsung common.
We have few Exynos4 boards in u-boot and in future we can introduce
common
board file for them too.
So it is better to add some additional word to this file name. This also
needs to change config name or add checking SOC version in common
Makefile.

Cannot we use the same file even for exynos4 boards.


I'm not sure that you understand my intention.

You want to introduce:
board/samsung/common/board.c - with only Exynos5 code

I mean that it should looks like this, e.g:
"board/samsung/common/board_exynos4.c" - common code for all Exynos 4
"board/samsung/common/board_exynos5.c" - common code for all Exynos 5
since there is some duplicated code in Exynos4 boards that can be moved to
one common file in the future.
Do you understand my intention now?

Yes I understood your intention,  but had a question cannot we use the
same file board.c for exynos4 and exynos5 too.
Since both have most of functions similar like board_init,  dram_init,
board_uart_init and so on.

If u still feel that exynos4 and exynos5 have lots of functions
different in board/samsung we can create a seperate file. I was hoping
the same board.c could be reused for exynos4 also.

Ah, ok. This is good idea with the one common file. Then we will have board files with strict board dependent functions. So I don't have any objections jet.
Regards,

--
Przemyslaw Marczak
Samsung R&D Institute Poland
Samsung Electronics
p.marc...@samsung.com
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to