And the rest:

+void KWalletManager::open()
+{
+    if (m_isOpening)
+        return;
+    if (m_wallet && m_wallet->isOpen()) {
+        QTimer::singleShot(0, this, SLOT(walletOpened()));
*cough* - and why does the call need to be deferred anyway?


+void KWalletManager::walletOpened(bool opened)
"finishOpening" or "slotOpened" - "walletOpened" sounds like a signal (actually 
is - different only
by parameter) and contradicts the initial "!opened" query


+void KWalletPasswordJob::walletOpened(KWallet::Wallet *wallet)
see above. in general slot names should describe what the slot does rather than 
when it's invoked
(the signals name should describe what happened instead)

+        goto error;
Jan has to comment this, but personally i would really recommend to avoid 
"goto" whenever possible.
In this case, eg. define

void KWalletPasswordJob::error(Type t)
{
   emit error(t);
   finished();
}


and then

if (!wallet->hasFolder(TrojitaFolder))
   return error(PasswordJob::NoSuchPassword);


+KWalletPassword::KWalletPassword(QObject *parent) : PasswordInterface(parent)
+{
+    /*
+      NOTE: This is only way how to set application name to KWallet widget.

Just to be sure:
+TrojitaPlugin::TrojitaPlugin(KontactInterface::Core *core, const QVariantList &) : 
KontactInterface::Plugin(core, core, "trojita")
+{
+    setComponentData(KontactPluginFactory::componentData());

is not the culprit here?


------

Cheers,
Thomas

Reply via email to