> On 16 May 2002 [EMAIL PROTECTED] wrote:
>
> > Date: 16 May 2002 21:30:22 -0000
> > From: [EMAIL PROTECTED]
> > Reply-To: Tomcat Developers List <[EMAIL PROTECTED]>
> > To: [EMAIL PROTECTED]
> > Subject: cvs commit:
> >     jakarta-tomcat-4.0/catalina/src/share/org/apache/naming/factory
> >     DbcpDataSourceFactory.java
> >
> > glenn       02/05/16 14:30:22
> >
> >   Modified:    catalina/src/share/org/apache/naming/factory
> >                         DbcpDataSourceFactory.java
> >   Log:
> >   Add support for the new DBCP Features.
> >
> >   Three new DBCP parameters were added:
> >
> >   removeAbandoned - True or false. If true abandoned db connections
> >   are removed after the removeAbandonedTimout is exceeded if the dbcp
> >   is nearing exhaustion.
> >
> >   removeAbandonedTimeout - Time in seconds since a connection was last
> >   used before it is considered abandoned.
> >
> >   logAbandoned - True or false.  If true Exception stack traces are
> >   created so that the source of an abandoned db connection can be
logged.
> >
>
> To avoid maintaining duplicate code for this kind of thing, what would you
> think about switching Tomcat to using
> org.apache.commons.dbcp.BasicDataSourceFactory instead, and made these
> changes over there?  That way, they would be available to non-Tomcat users
> of DBCP as well.
>
> (Historically, I wrote DbcpDataSourceFactory first -- but it really
> belonged in DBCP so it got copied to create BasicDataSourceFactory.)

Big +1. Maintaining duplicated code is a bad idea, and BDS appears like a
good wrapper for the PoolingDS.
The change is very easy: change the value of a constant, and remove the
current DBCP factory.

Remy


--
To unsubscribe, e-mail:   <mailto:[EMAIL PROTECTED]>
For additional commands, e-mail: <mailto:[EMAIL PROTECTED]>

Reply via email to