> - What's the point of having key_binding_map_value and > key_binding_map_entry? Why not just one key_table struct? > key_bindings_remove can remove it from the tree and unref it, the > unref func can free it when it hits 0. > > - Also if we just have key_table then key_binding_map could be renamed > to key_tables which is shorter.
I had mostly been trying to keep RB_* at arm's distance and use them as simply and as mimicked-from-existing-codefully as possible. I'll unify them. > - In unbind-key, looks like the -n and no flag table names are the wrong > way round? Yup, will fix. > - In bind-key, I see no need for a helper function - just do something like: > > if (args_has(args, 'T')) > table = args_get(args, 'T'); > else if (args_has(args, 'n')) > table = "root"; > else > table = "prefix"; > > cmdlist = .... > > key_bindings_add(table, key, args_has(args, 'r'), cmdlist); > return (CMD_RETURN_NORMAL); Will do. Keith ------------------------------------------------------------------------------ "Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE Instantly run your Selenium tests across 300+ browser/OS combos. Get unparalleled scalability from the best Selenium testing platform available Simple to use. Nothing to install. Get started now for free." http://p.sf.net/sfu/SauceLabs _______________________________________________ tmux-users mailing list tmux-users@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/tmux-users