Author: emaste
Date: Thu Apr  7 20:26:27 2016
New Revision: 297686
URL: https://svnweb.freebsd.org/changeset/base/297686

Log:
  Rename SHT_AMD64_UNWIND to SHT_X86_64_UNWIND per ABI doc
  
  From http://www.x86-64.org/documentation_folder/abi-0.99.pdf

Modified:
  head/sys/sys/elf_common.h

Modified: head/sys/sys/elf_common.h
==============================================================================
--- head/sys/sys/elf_common.h   Thu Apr  7 20:12:45 2016        (r297685)
+++ head/sys/sys/elf_common.h   Thu Apr  7 20:26:27 2016        (r297686)
@@ -415,7 +415,8 @@ typedef struct {
 #define        SHT_HISUNW              0x6fffffff
 #define        SHT_HIOS                0x6fffffff      /* Last of OS specific 
semantics */
 #define        SHT_LOPROC              0x70000000      /* reserved range for 
processor */
-#define        SHT_AMD64_UNWIND        0x70000001      /* unwind information */
+#define        SHT_X86_64_UNWIND       0x70000001      /* unwind information */
+#define        SHT_AMD64_UNWIND        SHT_X86_64_UNWIND 
 
 #define        SHT_ARM_EXIDX           0x70000001      /* Exception index 
table. */
 #define        SHT_ARM_PREEMPTMAP      0x70000002      /* BPABI DLL dynamic 
linking 
_______________________________________________
svn-src-head@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-head
To unsubscribe, send any mail to "svn-src-head-unsubscr...@freebsd.org"

Reply via email to